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Managing Projects 

In this chapter you learn how to: 

• understand naming conventions, 

• compact projects, 

• save a project to a zip file, 

• archive projects, 

• use the section check-out/check-in feature. 
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Overview 
When you create a project using SpecLink, you have invested a significant effort in 
customizing the master data for your needs. Therefore, you want to make sure that you 
manage the files to maintain their integrity and have them available for future use and 
reference. 

The system resources you need as you continue to create specification projects may limit 
the number of projects that can be active on your system. Therefore, SpecLink provides 
compacting, zipping and archiving tools. 

Using the section check-out feature will significantly increase editing speed. 

Project Maintenance Tools 
This section describes some of SpecLink’s project management tools, including 
compacting, compressing and archiving projects.  

Naming Conventions 
The file name of the project (the name you enter in the New Project dialog box when you 
first create the project) should be a meaningful name that is easily recognized by other 
team members. Once the project is created, you can enter the official Project Name and 
any ID for the project in the Summary Information dialog box. The Project Name and 
Project ID are keywords that are available for use in headers and footers. The file name 
does not appear anywhere in the project. 

SpecLink automatically assigns the extension .SPP to projects that you create. Three other 
extensions are recognized by SpecLink: .PRS which is the extension of previous 
PerSpective project files, .SPT which is the extension on the BSD master template (the 
default Project Source when you install the software); and .SPM which is the extension of 
the BSD master database which you cannot edit and which is the underlying basis of every 
project. 

For your office master, you may choose to change the extension to .SPT in Windows 
Explorer. This way other users would be able to select it as their Project Source, but would 
not be able to open and edit the file without first changing the extension back to .SPP. 

NOTE: For more information on creating an office master, see Chapter 10. 
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Compacting Projects 
Because SpecLink uses a sophisticated relational database, considerable system 
resources are required to provide comprehensive information. At times, it may make sense 
to "compact" a project. You can save disk space by eliminating the system space resources 
used to maintain deletions. This is particularly useful if you have removed whole sections of 
a project. For example, if you use the SpecLink master to create a Master Project File 
containing limited sections, you can compact the project to reduce the system space used.  

1. From the File menu, choose Repair/Compact Project. Be sure the project you want to 
compact is not in use or you will receive an error message. 

 The Repair and Compact Database dialog box opens.  

 

Repair and Compact Database Dialog Box 

2. Choose the file name of the project you want to compact. 

You may have to choose a different drive or directory if the project you want is stored 
there. 

3. Click Open. 

 The selected project is repaired and compacted. You receive a confirming message 
that the repair/compact process was successful. 
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Archiving Projects 
There are two ways to archive project work: 

• Export it. See the "Exporting to a Word Processor" section in Chapter 8 "Printing" for 
instructions. 

• Back it up. 

Making Backups of SpecLink Projects 
One of the most important things you can do to safeguard the work you have put into 
creating specification projects is to make regular backups of the project database files. 
While the SpecLink software and master database files can be replaced, the only copies of 
the project files you create are the ones you make.  

Be aware that files can be deleted accidentally or hardware problems with your computer 
can serve to make your databases unusable. Recreating the project files can require a 
significant amount of work, even if hard copy printouts exist. You can avoid losing the files 
by making frequent backup copies that can be used to restore the data. 

NOTE: When you update a project, you are offered the opportunity to make a backup 
copy of your project automatically, which we strongly recommend you do in 
addition to your other backup procedures. See Make Project Backup Before 
Update in Chapter 11 “Updating.” 

Ideally, backup copies should be created each day that work is done on your specification 
files. It may even be desirable to keep backups at a site other than the one where you 
normally work. You can create backups manually, or purchase utilities that will create 
backups automatically. 

Manual Backups 

You create manual backups by storing copies of your project files on your server, CDs, 
other drives, or any data storage device you choose. We recommend that you use Save to 
Zip File on the File menu to create zip files of your project and then save the zipped files as 
your backup. This is for several reasons: 

• File size: Zipped files are much smaller than unzipped files so the backups will take up 
less space. 

• Reduced chance of editing wrong file: Zipped files must be unzipped in order for 
SpecLink to recognize and open them. In a multi-user environment, this will aid in 
keeping users from accidentally editing the backup instead of the current file. 
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• Read-only property of CDs: When files are copied to a CD, they inherit a read only 
property (except when using Windows/XP). When they are copied back to a hard 
drive, they keep the read only property. Read only files cannot be opened in SpecLink. 
In order to access a project on a CD, it must be copied to the hard drive whether it is 
zipped or not. And if it is not zipped, the read only property must be turned off. This 
means unzipped files require two steps in order to access them, while zipped files only 
require one – extracting to the hard drive. 

Zipped files are also usually small enough to be emailed, and with the latest version of 
WinZip you can break a larger zipped file into multiple smaller zipped files which can be 
emailed separately. If you are working on a specification with another company that also 
has SpecLink, you can zip the project file and email it. 

Automatic Backup Utilities 

Microsoft XCOPY or BACKUP  

Microsoft provides backup routines with its operating systems, but they typically are not 
compression-type utilities and are not adequate for BSD SpecLink project files. 

Third-Party Backup Software  

Other companies produce commercial backup software capable of making archive copies 
of your data files. 

Backups to Tape 

A magnetic tape drive is an ideal method for making archive copies of your files. Tapes are 
typically inexpensive, hold a large amount of data, and provide a medium that can be 
stored easily.  

Save to Zip File and Load from Zip File 
Use these commands on the File menu when you want to zip a SpecLink project in 
compressed format, or to retrieve a previously zipped database. 

To save a project to a zip file: 

1. Close the project you wish to compress. 

2. Choose File > Save to Zip File. 

 The Select Unopened Project Database to be Compressed dialog box opens. 
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Select Unopened Project Database to be Compressed dialog box 

3. If desired, click on the drop down arrow in the Look in field to navigate to another 
folder on your hard drive or file server. 

4. Click on the project to be compressed and then click Open. 
 

 The Select Compressed File Path dialog box opens. 
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Select Compressed File Path dialog box 

5. If desired, click on the down arrow in the Save in: drop down box to navigate to another 
folder. 

6. Click Save. 
 

SpecLink compresses the database and informs you when process is complete. 

NOTE: The Save to Compressed function will automatically span multiple floppy disks. If 
you select a 3.5” floppy disk as the destination (usually the A drive) in step 5, 
SpecLink will prompt you to insert a disk, and when the disk is full, it will ask for 
another. 

To extract a compressed database: 

1. Choose File > Load from Zip File. 

 The Select Compressed File Path dialog box opens. 

2. Use the dialog box to select the compressed database you want to extract. Click 
Open. 

 The Select Destination directory for Project Database dialog box opens. 

3. Use the dialog box to navigate to the drive and path where the file should be placed, 
and then click OK. 

 SpecLink extracts the compressed database to the selected drive and path and then 
opens it. 

NOTE: If a database of the same name exists in the folder, SpecLink prompts you to 
confirm overwriting it. You can overwrite the file, place the new file in a new 
location, or Cancel. 

Section Check-Out | Check-In 
SpecLink includes a Section Check-Out | Check-In feature to increase the speed of the 
editing process. When you check-out a section, the links to and from other sections are 
temporarily suspended, increasing the processing speed of your edits. Those links will be 
implemented when you check it back in. While checked out, a temporary copy of the 
section is stored on your local drive, separate from the project file. Any other users who 
open the project see a red key indicating that you have the section checked out. Other 
users can edit and/or check-out other sections in the same project. 
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Use with Local Installations 
Checking-out sections increases editing speed even when the project is stored on the local 
drive. While the section is checked out, SpecLink is only processing links within the 
checked out section, which increases editing speed. 

How to Check-Out a Section 
To check-out a section: 

1. Open the project that contains the section that you want to check out. 

2. In the Tree panel click on the name of the section to be checked out. 

3. On the Document menu, point to Check Out | Check In, and then choose Check Out 
Document. 

 A confirmation message opens. 

 

Check Out Section confirmation message 

4. Click OK to check-out the section. 

 SpecLink makes a temporary copy of the section on your local drive. The Tree Panel 
closes. 

Section Check-Out Results 
When a project with checked-out sections is opened by another user (if you have a multi-
user license) or by the same user in a new window, the section(s) that are checked out 
display in gray type in the Tree panel, with a red key instead of a status box, and a 
message identifying who has the section checked out.  

 

Display of checked-out section in Tree panel 
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With a multi-user license, other users can click on the name of the section to view it in the 
Document panel. The text of the checked-out section will display on a gray background, 
and the other users will not be able to edit the section while it is checked-out. 

NOTE: A section displaying in gray with the “in use” information as above, but without 
the red key, is being edited or viewed by you or another user, but is not checked 
out. 

Opening Another Section While Working in a Checked-Out Section 
To open another section in the same project, use the list of open windows at the bottom of 
the Window menu to toggle between the checked-out section and the project. You can also 
choose one of the Tile or Cascade options in the Window menu to display all open 
windows at the same time. 

You will not be able to check-out an additional section; however, you will be able to copy 
information from one section to another. If the section you want to copy from is in use or 
“checked out” by another user, you will not be able to copy from it. 

NOTE: Many SpecLink functions are unavailable while you are in a checked-out section. 
Check the section back in to use these commands. Unavailable commands 
include Summary Info, Show Header/Footer, all commands for working with the 
Tree Panel, commands for managing sections on the Document menu, 
Customize Styles, Import From Project, Rebuild Project Links, Compare 
Projects, and New Window (although you can click on the Window menu to 
open the Project Tree and can then select another section for viewing and/or 
editing while you have a section checked out.) 

How to Check-In a Document 
When you have finished editing a checked-out section, you will need to check the section in 
before anyone else can access it. There are a couple ways to check-in a section: 

• While viewing the checked-out section, on the Document menu, point to Check Out | 
Check In, and then choose Check In Document. A message will open to confirm that 
you want to check-in the section. Choose OK to check-in the section. 
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Check In Section confirmation message 

• You can also check-in a section by closing. If you close SpecLink while you have a 
section checked-out, or if you close the window containing the checked-out section, 
SpecLink will prompt you to check the section in. Choose OK to check-in the section 
and close. 

 

Check In information message 

NOTE: If SpecLink or your computer crashes while you have a section checked out, 
reboot your computer, open the project, click on the name of the checked-out 
section (it will still have a red key icon), and on the Document menu, point to 
Check Out | Check In, and then choose Check-In Document. 

Undo Document Check-Out 
Use the Undo Document Check-Out command, available in the Document menu under 
Check Out | Check In, to discard all edits made in a checked-out section. If selected while a 
section is checked-out, a confirmation message opens. 

 

Undo Section check out confirmation message 

If you choose OK, the checked-out copy is deleted, and the copy in the project is made 
available again in the same state as it was before being checked-out.  


