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  Welcome 

Welcome to a cost-estimating package specifically designed for architects and engineers. BSD 
CostLink®/AE is a subscription service that includes annually updated cost data from industry leader RS 
Means. CostLink/AE combines unlimited telephone support and regular software updates with over 
11,000 systems and assemblies, 75 building cost models, 22,000 line items, and cost indices for over 725 
U.S. and Canadian locations in a single subscription. 
 
You construct an estimate in CostLink/AE either by starting with one of the 75 building cost models or by 
using drag-drop or copy-paste of entire building systems, assemblies, and line items into a project 
hierarchy, either pre-defined or constructed on the fly. AE makes it easy to place project and data 
windows side-by-side, assigning cost items to appropriate project elements. If you start with one of the 
building cost models, you can select the exterior closure, input the building area and perimeter, select 
appropriate additives, and quickly generate a budget estimate. You can scrutinize any or all of the 
assemblies and line items that make up that model estimate and substitute other RS Means assemblies 
or line items, modify any of them, or add others. The model-generated estimate can be refined right up 
until contract documents are issued, so there should be no surprises when the bids are submitted. 
 
The system includes templates for Uniformat II, MasterFormat (both 95 and 2004) and a User-Defined 
hierarchy, as well as sample projects. A tab on the Summary Info dialog box allows you to choose a 
location (simply select your state and city) for automatic adjustment of your estimate, and you can also 
accept or modify prime contractor markups and sales tax values. The same tab lets you assign 
percentage markups for other costs such as contingency, escalation, and architect's fees. The RS Means 
data included with your subscription provides installed costs that encompass all labor, materials, 
equipment, and subcontractor overhead and profit. RS Means data is structured in intuitive hierarchies 
just like the books; Uniformat II for building systems and assemblies, the new 2004 MasterFormat 
divisions with breakdown for individual line items. Use the Find feature to locate any title, assembly, or 
line item regardless of hierarchy. 
 
CostLink/AE also supports dynamic linking from Microsoft Excel. Create a space program or building 
parameters model in Excel, and link cells directly to CostLink/AE quantities. Once linked, quantities in 
CostLink/AE update as the space program and other parameters change. 
 
Simple but powerful report formatting and presentation lets you choose and format your reports in a 
variety of ways. Each report can either include markups in the individual line items, or summarize 
markups at the end of the report—it's your choice. And you can choose the level of summarization, 
include or exclude a “percent of total” column, unit cost column, quantity column, and even the total cost 
column. You can also specify a report title and footer, apply your company's logo to the report, and 
choose whether to include notes in the report. AE lets you annotate any or every line of your cost 
estimate. Reports can then be printed or exported to a number of formats, including PDF, Excel, and 
Word. 
 
CostLink/AE is both new and mature, because it is solidly founded on the CostLink/CM framework, tested 
and improved through three generations of release. BSD has designated CostLink/AE as the new 
vanguard of its cost estimating product line. We know you will be pleased, both with your initial release 
and the ongoing subscription updates that hallmark our other successful products. We look forward to 
your productive use of CostLink/AE, and as always, we welcome your feedback. 
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  Learning about BSD CostLink/AE 

CostLink/AE is designed to be as intuitive as possible. If you are familiar with other Windows programs, it should 
be easy to learn CostLink/AE’s basic operations and data navigation. If you are new to Windows, it would be best 
to learn the fundamental Windows conventions before using CostLink/AE for the first time. At a minimum, you 
should understand how to open several windows concurrently and display and re-size them for greater 
productivity. 

On-Line Help 
On-line Help will get you answers fast, without having to read through a lot of instructions. The sizable Help 
window stays "on top" while you follow the instructions, rather than disappearing as soon as you click elsewhere, 
like other windows. This allows you to check the instructions as you work, without backtracking to find your place 
in Help again. 

User Manual  
The BSD CostLink/AE User Manual is available on the CD for your use, or for download from BSD’s website: 
www.bsdsoftlink.com. 

The User Manual files are saved as PDF files. The files are in the AE_Doc folder on the CD. 

Check out the table of contents and the index for more detailed topics. 

User Manual 
Title Page  cover.pdf 
Table of Contents  contents.pdf 
Preface  preface.pdf 
Chapter 1 Introduction 01-introduction.pdf 
Chapter 2 Tutorial 02-tutorial.pdf 
Chapter 3 About the CostLink/AE Display 03-display.pdf 
Chapter 4 Project, Tasks and Markups 04-project.pdf 
Chapter 5 Reports 05-reports.pdf 
Chapter 6 Tools and Techniques 06-tooltech.pdf 
Chapter 7 Linking to Excel 07-linking.pdf 
Installation Installation Instructions AEInstallation.pdf 
Appendix A Toolbar and Menu Reference appa-toolmenu.pdf 
Appendix B RS Means Abbreviations appb-abbreviations.pdf 
Index  index.pdf 

Technical Support 
Your subscription to BSD CostLink/AE includes unlimited technical support. In order for you to fully evaluate the 
product, we encourage you to evaluate our excellent product support team. They can be reached by phone, fax, 
or email and are available Monday-Friday, 8:30 am to 5:30 pm, Eastern time zone. In the event that all support 
staff are engaged, please leave a message and your call will be returned promptly. 

Direct Line: 800-266-7732 or 404-365-9226 
Fax: 404-365-8912 
Email: support@bsdsoftlink.com 
Internet home page at http://www.bsdsoftlink.com for new product development and other news. 
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  Installation 

BSD CostLink/AE System Requirements 

BSD CostLink/AE was designed to operate in 32-bit Microsoft Windows environments and to take advantage of 
the additional features and power of those platforms. Those environments include Windows Vista, XP and 2000. 

Listed below are detailed hardware and software recommendations for operation of BSD CostLink/AE. As with 
any Windows application, faster system components and more system memory will enable superior performance 
of the software. Higher resolution video cards and monitors will enable more information to be displayed on the 
screen. 

 

  Hardware and Software Recommendations 
Recommended Configuration 
 
• Intel-compatible processor, 1 Ghz or better 
• Windows™ Vista, XP or 2000 
• 512 megabytes of RAM (256 minimum) 
• 500 MB of available disk space 
• 17-inch or 19-inch XGA monitor 
 (1024 x 768 resolution and matching video card) 
• 32x CD-ROM reader 
• 600 dpi laser printer and matching driver 
• Internet Explorer 5.5 or higher (5.0 minimum) 
• Microsoft Excel 2000 (version 9.0) or higher if using the Excel linking feature 

Installing BSD CostLink/AE 
Prior to installing BSD CostLink/AE, it is best to upgrade your operating system to the latest version, if necessary. 

If you upgrade to a new Service Pack, BSD recommends that you choose to back up your previous version of 
Windows if space permits. 

Other Windows applications should be closed before proceeding with the installation. This is because certain 
types of system software used in many applications can interfere with the installation process. 

CostLink/AE installation is performed from the CD-ROM or download file. Perform the following steps: 

• Close all applications, including any virus scanning software. 

• Upgrade your operating system, as noted above, if needed. 

• Insert the BSD SoftLink CD-ROM or double click on the downloaded installation file. 

• The BSD SoftLink Product Suite Installation Program will start automatically. (If you have turned Autorun off, 
then you can start the installation by selecting Run from the Start menu, then type in D:\setup (where D is the 
drive letter of your CD-ROM reader) and click OK.) 

• Follow instructions to complete the installation, referring to the additional notes below. 
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NOTE: Note: For complete installation instructions print the Installation document, available on the Install 
Products screen of the BSD SoftLink CD ROM. It, along with the user’s manual, is also available on our web 
page at http://www.bsdsoftlink.com/costlinkae/ae_subscribers.htm.  
 

By default, the installation will be made to C:\CostLink AE. You may choose to have the software loaded to a 
different drive and/or folder. Click on the Browse button to change the installation location. Your computer system 
will be checked to see if there is enough available disk space to install CostLink/AE.  

Note: Depending on what files are already installed on your system, you may be asked to restart your computer 
before proceeding to run the CostLink /AE software. YOU MUST DO THIS to properly register all components 
necessary for operation of CostLink/AE. 

 

Installation Choices 
There are two installation choices: 

A. Standalone Installation 
B. Network Server Installation 
 

For evaluation purposes, we suggest you select Standalone Installation. See the User Documentation for 
information about network installations. 

User Permissions  
 
The first time you start CostLink/AE, a dialog box will be displayed noting that a valid access key is 
required. You must contact your Sales Representative to be set up for a CostLink/AE evaluation. 
 

 
 
After clicking OK, a dialog box is displayed for display of an Access ID and entry of the Access Key. 
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To use the software, you must enter a valid access key in the Access Key field and then click the Apply 
button. Call BSD Technical Support direct at 800-266-7732 or 404-365-9226 to receive an access key. 
(You must first arrange for an access key with your Sales Representative.) 
 
Once a valid access key has been entered and you click OK, the key will be stored, and CostLink/AE will 
start. You can then open one of the sample projects, or you can create a new project. Chapter 2 of the 
User Manual on the CD contains a tutorial that will guide you through the process of creating a new 
project. 
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  CostLink/AE Overview 

Panels and Windows 

Opening an Estimate 

When you first start BSD CostLink/AE, the program opens with an empty window. 

 

 

To Open an Estimate 

1 Choose File > Open, and select Project Database from the submenu. 

 The Open Database dialog appears, displaying the sample projects that were installed with the 
software.  

2 Select the Fire Station Sample Project and click Open. 

 BSD CostLink/AE opens the project and displays it in its own database window—that is, a window 
within the BSD CostLink/AE main window. 
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This is the default window setup for BSD CostLink/AE. The top panel is called the tree panel and 
the panel at the bottom is called the sheet panel.  

Definitions 
The tree panel shows the hierarchical organization of the project (or other database). You can expand 
and collapse the tree to see different levels of the database structure, and you can apply a number of 
other configuration controls, as described below. 

The folders shown in the tree panel represent different categories of work within the project (or other 
database). You can define a project with any number of levels of hierarchy, so that a given folder may 
have many folders (or children) beneath it and some levels of folders (parents) above it. 

The sheet panel is used to display and edit project data. In the project hierarchy, the items listed in the 
sheet panel are always located one level below the folder currently selected in the tree panel. 

The items in the sheet panel can either be folders or tasks. Tasks represent the estimated cost 
information for pieces of a project. 

Expanding and Collapsing the Tree 
You can control the display of data in the tree panel in a number of ways. Try the following: 

• Click on the plus sign on any folder shown in the tree panel. 

The view expands to show the next level down. 
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• Click on the minus sign to bring the folder back to its original view. You can also the tree menu 
to expand all folders in the project, or just one branch.  

Arranging Panels and Windows 
The View Menu contains additional functions for controlling the display. You can arrange the panels 
vertically or horizontally. When you have more than one database window open in BSD CostLink/AE, you 
can use the following toolbar buttons to arrange them.  

Click on the following buttons. (Equivalent commands are located on the Window menu). 

 Tile windows vertically. Arrange the windows side by side. 

 Tile windows horizontally. Arrange all open windows one atop 
the other. 

 Stack windows in cascade. Arrange the windows in cascade 
fashion. 

Showing Costs in the Tree Panel 
You also have the option of showing costs for each folder in the tree panel. These costs are the 
summarized costs for all tasks contained in that folder. To show cost information, choose Show Data in 
Tree on the Tree menu. The BSD CostLink/AE display now looks like this. 
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Forms 
In addition to the tree and sheet panels, BSD CostLink/AE can display detailed information about each 
folder and task on a form. You can use forms to both view and edit information. 

Folder Forms 
Item forms for folders show descriptive information about the category that the folder represents. In an 
estimate, the folder item form also shows the summary of cost information for that category. 

To view folder item forms 

1 Click on Tree > Expand All. 

2 In the tree panel, select the SUBSTRUCTURE folder.  

3 Click the Open item form on the tree panel button on the toolbar . 

 The folder form opens: 

 

4 Notice the buttons at the bottom of the form. Click the Next button. 

 The item form changes to display information for the next folder on the tree panel, 
FOUNDATIONS. 

5 Click the Next and Back buttons to move through display of the folder item forms. When you 
are ready, click Close. 
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Task Forms 
Tasks forms show descriptive and detailed cost information about tasks. 

To view task forms 
1 In the tree panel, select the Strip Footings Folder. 

2 In the sheet panel, double click on the one task under this folder, called Strip footing, concrete, 
reinforced, load 11.1 KLF, soil bearing capacity 6 KSF, 12" deep x 24" wide. This will open the task 
form. 

Note: There are two additional ways to display task forms: 

Context menus: first click the right mouse button on the item in the sheet panel. Then, from the 
context menu that appears, select Edit Item. The task item form appears. 

Using the View menu, click on Sheet Items Form, or use the Sheet Items form icon on the Toolbar. 

 

Notice that the task form has more information than the folder form. Since the task is an assembly, the 
Assembly Members grid of the form displays the RS Means line items that make up this assembly. Click 
Close to close the task form.  
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Tabs 
By default, BSD CostLink/AE shows the level 1 Folders of the project hierarchy on separate tabs within 
the project window. The Fire Station Sample Project, for example, has two folders at the top level, one for 
the fire station and one for Sitework. Each of these divisions of the estimate is shown on a separate tab. 

 

Showing All Data on One Tab 
 

You can choose to show all of the data in the project on a single tab. Select Tree  > Use Single 
Tab to accomplish this. The project window now looks like this: 
 

 
 
Showing multiple tabs is useful in complex estimates. 
 
For now, return to the default view by choosing Tree > Use Single Tab again. 
 



B S D  C o s t L i n k \ A E  –  E v a l u a t i o n  N o t e s  

12  

A Look at the Cost Data 
1 On the BSD CostLink/AE toolbar, click the Open Assembly Resource Window . 

 BSD CostLink/AE opens the assemblies resource view in its own window: 

 

3 For a better view, click the maximize button in the upper right of the window. 

 
 The RS Means assemblies data is displayed with multiple tabs, one for each of the Uniformat 

Systems, which are used to organize the data. 

4 Using the navigation techniques you've learned so far, spend some time exploring the RS Means 
Assemblies. 

• Click on different tabs to view different parts of the database 

• Expand and collapse the tree to view data at different levels of the hierarchy. 

• Examine some assemblies by opening the Item form in the Sheet, with an assembly 
selected.  

5 Close any item forms so that only the tree and sheet panels are displayed. Now click the Tile 
windows vertically button  on the BSD CostLink/AE toolbar. (If you are still displaying the data in 
the project Tree panel, you may want to turn it off.) 
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 BSD CostLink/AE displays the Project and Assemblies windows side-by-side. This arrangement is 
useful when you are copying tasks from one database to another, especially when using drag-and-
drop. 

6 To close the Assemblies, click the close button  in the upper right corner of the window. Click the 
maximize button  to maximize the Fire Station Sample Project Database window. 

Reports 
BSD CostLink/AE provides clean reports for presentation to clients. The Summary report can display 
costs at the folder level you choose. A Detailed Estimate is also available to itemize the assemblies and 
line items in your project. Click on the File > Reports Setup to choose and format your reports. See 
Chapter 07-reports.pdf, in the AE_Doc folder on the BSD SoftLink CD for more information on formatting 
and printing reports. 

 

Starting a Project Using a Model 
You are now ready to start a sample project using a model. You may already have an existing cost estimate that 
you would like to try to replicate in AE. 

Chapter 2 of the BSD CostLink/AE User Manual, located in the AE_Doc folder on the BSD SoftLink CD or from 
our web page, walks you through the steps of starting a project from a model, copying assemblies and line items 
into your project, applying markups, and creating reports. It is suggested that you print this chapter before 
continuing your evaluation. 


